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Remote Sensing and GIS has found diverse applications in forestry.  For monitoring 
and assessment of forest resources, use of Remote Sensing and GIS has now become 
inevitable. With the implementation of National Working Plan Code 2014, there is 
extensive use of GIS in preparation of working plans. In this scenario, it is need of the 
hour to develop capacity of the State Forest Departments in using GIS software 
which are easily available to the users and are easy to operate.

Quantum GIS (QGIS) is one such software which is a freely downloadable and open source software of 
GIS applications. QGIS provides excellent capabilities, stable operation and support numerous vector, 
raster, database, formats and functionalities. Like other GIS applications, QGIS provides a 
geographical user interface wherein different layers of spatial data can be displayed and analysed. 
Many commercial GIS software available in the market are very expensive and cost a huge financial 
burden on users not only in purchasing licenses but also for their annual maintenance.

Considering numerous uses of GIS in different forestry applications and heavy cost of proprietary 
software, FSI has included modules on QGIS in its training programmes to develop capacity of the 
State Forest Departments (SFD) in use of QGIS.

The Manual of Quantum GIS for Basic Forestry Applications Version 1.0, developed by FSI is a step in 
popularising QGIS in the SFDs. The manual contains different chapters describing the basic concepts 
of QGIS and easy to understand steps illustrated through screen shots of GUIs. The manual will enable 
users to understand and perform basic GIS analysis such as geo-referencing, creating geo-spatial 
layers, vector processing, map composition etc.  

I acknowledge the sincere efforts done by Dr. Madhu Bist, Project Scientist in preparing this manual. 
She has developed deep understanding of different functionalities of QGIS software. Contributions of 
Shri Sushant Sharma JD (TFID) and Shri Prakash Lakhchaura DDG are acknowledged. Thanks are also 
due to other officers and staff of FSI who have contributed in preparation of the manual.  I hope, the 
manual will be immensely useful to the SFDs.  FSI is in the process of developing an advanced manual 
on QGIS also for different forestry applications and the same will be shortly made available to the 
users.

Preface

23 May, 2019         (Dr. Subhash Ashutosh)
Director General, FSI
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CHAPTER 1:

QUANTUM GIS

QGIS is an Open Source Geographic Information System. QGIS was first developed and established as 
a project Source Forge in 2002. QGIS known as Quantum GIS is a cross-platform, free and open source 
Geographic Information system (GIS) application that provides capability of data viewing, editing and 
analysis of spatial data. QGIS allow users to create maps with many layers using different map 
projections. It currently runs on multiple operating systems, most Unix platforms, Windows, and 
macOS. QGIS is developed using the Qt toolkit (https://www.qt.io) and C++. Therefore, easy-to-use 
graphical user interface (GUI). QGIS aims to be a user-friendly GIS, providing common functions and 
features. The initial goal of the project was to provide a GIS data viewer.

QGIS supports a number of raster and vector data formats. QGIS supports vector, raster and database 
formats. It supports many common spatial data formats (e.g. ESRI Shapefile, geotiff) with new format 
support easily added using the plugin architecture.

QGIS is released under the GNU General Public License (GPL). Developing QGIS under this license 
means that you can inspect, modify the source code and always have access to a GIS program that is 
free of cost and can be freely modified.

What QGIS can do?

· View spatial data.
· Digitise points, lines and polygons.
· Import GPS data in GIS layer, view GPS data (point, line, polygon on Google earth).
· Georeference Satellite images including Google earth images.
· Measure  area, perimeter, length .
· Compose maps on desirable scale.
· Create buffer along the roads around the villages, forest etc.

Note:                                       Installation of QGIS Software

· Insert the Compact disc (CD) where the Software is saved.
· Double click on QGIS .exe setup file and click on next button.
· Read the License Agreement and click on I Agree button.
· Choose the location (Local Drive) you want to install the software and click on next button then 

click install.
· Please wait while installation and extraction process is in progress.
· When installation is completed, click on Finish button and open the software.
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1.1 QUANTUM GIS GRAPHICAL USER INTERFACE

When QGIS starts, you are presented with the GUI as shown in the figure:

The QGIS GUI is divided into five areas:

1. Provides access to various QGIS features using a standard hierarchical menu. 

2. Provides access to most of the functions as the menus, plus additional tools for 
interacting with the  map. 

3.  Lists all the data layers in the project. This area also allows to change style or label 
the layer. 

4. The map displayed in this window will depend on the vector and raster layers you 
have chosen to load. 

5. The status bar shows you your current position in map coordinates as the mouse 
pointer is moved across the map view.

· Using these five areas (as mentioned above), you can add a data layers, zoom to a specific area 
in the data, hide or show relevant layers and see the coordinates, scale and projection of your 
displayed map.

NOTE: You can use middle button of your mouse to pan the map.

Menu Bar: 

Tool Bar: 

Map Legend:

Map View: 

Status Bar: 
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CHAPTER 2: 

GEOREFERENCER PLUGIN

· The Georeferencer Plugin is a tool 
for generating world files for rasters. 
It allows you to reference rasters to 
geographic or projected coordinate 
systems by creating a new GeoTiff 
or by adding a world file to the 
existing image. The basic approach 
to georeferencing a raster is to 
locate points on the raster for which 
you can accurately determine 
coordinates.

Table: Georeferencer Tools

· As X and Y coordinates (DMS (dd mm ss.ss), DD (dd.dd) or projected coordinates (mmmm.mm)), 
which correspond with the selected point on the image, two alternative procedures can be used:

(i) Enter the GCP's (Ground Control Points) by specifying coordinates manually:
It involves selecting multiple points/ GCP's on the raster, specifying their coordinates, and 
choosing a relevant transformation type. The more GCP's provides the better would be the 
result.

(ii) Using already georeferenced layers:
The georeferenced layer can be either belong to vector or raster data that contain the same 
objects/features that you have on the image to georeference. In this case, you can enter the 
coordinates by clicking on the reference dataset loaded in the QGIS map canvas.

· To start georeferencing an unreferenced raster, we must load it using the      button. The raster 
will show up in the main working area of the dialog. Once the raster is loaded, we can start to 
enter reference points.

· Using the         Add Point button, add points to the main working area and enter their coordinates 
(see Figure). For this procedure there are three options:

2.1 Entering ground control points (GCPs)
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a. Click on a point in the raster image and enter the X and Y coordinates manually.

b. Click on a point in the raster image and choose the      from map canvas button to add the X 
and Y coordinates with the help of a georeferenced map already loaded in the QGIS map 
canvas.

c. With the      button, you can move the GCPs in both windows, if they are at the wrong place.

2.1a (i) Add GCPs

· To add GCPs go to Raster  > Georeferencer > Georeferencer.
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· Then Georeferencer window will appear as viewing in the figure below. 

· Click on       to add points and place first GCP point in top left corner. 
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2.1a (ii) Defining the transformation settings

· After you have added your GCPs to the raster image, you need to define the transformation 
settings for the georeferencing process.

· Go to Settings > Transformation Settings and set transformation parameters accordingly.
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Change Transformation 
type from Linear to 
Polynomial

 

2.1a (iii) Define the Resampling method

The type of resampling you choose will likely depending on your input data and the ultimate objective 
of the exercise. If you don't want to change statistics of the image, you might want to choose 'Nearest 
neighbour', whereas a 'Cubic resampling' will likely provide a more smoothed result.
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2.1a (iv) Running the transformation

After all GCPs have been collected and all transformation settings are defined, just press the    Start 
georeferencing button to create the new georeferenced raster.

 

Q-GIS MANUAL    Page 08



2.2 Assigning GCP's by using georeferenced layer
Georeferencing is the process of assigning real-world coordinates to each pixel of the raster. The 
method involved reading the coordinates from reference (already defined map projection) or scanned 
map and inputting it manually by identifying similar features in input and reference image as well.

· To enable the Georeferencer for the first time, go to plugin from Plugins > Manage and install 
Plugins > Installed.

· Now, the plugin is installed in the Raster menu.

· First of all, open referenced image/base image (georeferenced toposheet) on map canvas.

· Go to open a GDAL supported Raster data source and browse for the georeferenced file. 

Click here to open 
georeferenced file

 

· To start georeferencing of input image (satellite imagery) by taking reference of already rectified 
image (SOI toposheet), launch the Georeferencer from Raster.
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· Then georeferencer window will appear on map canvas as showing in Figure.
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· Click on Raster > Georeferencer > Georeferencer to open the plugin.



· In the Georeferencer window, go to File > Open raster > Navigate to the downloaded tif/jpg file 
and click Open.

· Input file will appear on georeferencer window as showing in figure.

· We can display a color composite of bands in the Working toolbar, click the list RGB > and select 
the item 3-2-1 (corresponding to the band numbers in Band set). 

· Go to layer properties/Style by going to settings > Raster properties > and put Band 3 in the Red 
band, Band 2 in the Green Band and Band 1 in the Blue band.
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Click here to add 
control point 

· Now click on the Add Point button on the toolbar and select an easily identifiable location such as 
junctions, corners, intersections, poles etc on the image to get good control points.

· Once click on the image at a control point location, we will see a pop-up asking about to enter 
map coordinates. 

  

Click here to add points 
from map canvas

· Click the button From map canvas.
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· Now, find the same location in your reference layer, i.e SOI toposheet in map canvas and place 
GCP by clicking on similar identified feature. 

· The coordinates are automatically populated by clicking on the map canvas.

· Click Ok.

· Similarly, choose at least 4 points on the image and add their coordinates from the reference 
layer.
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Base
 

layer 
(Geo-

 

reference

 

Click here 
to start 
geo-  
referencin

 Input layer (to be 
georeferenced)  



· Now go to Settings > Transformation settings > choose the settings as showing in Figure. Ensure 
to check Load in QGIS when done button to open the georeferenced layer by its own after 
running algorithm .

· To run the process, go to Georeferencer window > go to file > start georeferencing or directly click 
to     start georeferencing button. This will start 
the process of warping the image using the GCPs 
and creating the georeferenced raster.

· Once the algorithm finishes, the georeferenced 
layer loaded in map canvas of QGIS.

· To validate the accuracy of georeferenced file, 
load and overlay the referenced file on created 
georeferenced file.

· To remove the black and white, (black or white 
pixels in the image are no-data values and 
should be made transparent). Right click on the 
image layer > choose Properties > Switch to the 
Transparency tab.
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 Outer 
black 
area

 



· Specify Input 0 as the No data value in additional no data value. Now in the Custom transparency 
options > click the + button  >  and add 255 as the transparent pixels for each band > and enter 
100 as the Percent transparent > Click OK. Now it will remove the outer black area from the image.

· To open Transparency slider in layer panel again Right click on top layer > properties > legend > 
select Transparency slider > select button
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· Now the transparency slider will appear in Layer panel and accordingly by sliding we can set 
transparency and validate the results, if georeferenced layer is overlapping properly on 
base/referenced layer.

· In the given Figure, we will see that georeferenced image accurately overlaid on the base layer.

NOTE: If in case the output is not satisfying, it can be further improved by taking more number of 
control points.

 

Transparency 
window will 
appear here 

 



CHAPTER 3: 

DOWNLOADING GPS 
DATA IN QGIS

3. (a) After installing QGIS software (refer to the base at the bottom) in the computer, open QGIS 
software.

3. (b) In the Menu Toolbar, click Vector menu > click on GPS>choose GPS tools.

 

3. (c) When GPS tool is activated small box will appear in the Map Canvas

3. (d) In the GPS tool box >click download from GPS option

3. (e) In the GPS device select  >Garmin serial.

3. (f) In the port option select usb.

3. (g) In the features type option select waypoint, track, routes (choose any feature you want to 
transfer).

3.(h) In the layer name > specify or type any name.

3.(i) In the output file option > specify the drive and folder to save the output> click ok.

(After the transfer is done GPS data will automatically display in the map canvas of  QGIS).
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4. (a) To create a new layer for editing choose new layer vector from Layer menu >
Click on new shapefile layer.

CHAPTER 4: 

CREATION OF NEW 
SHAPEFILE IN QGIS

 vector 
layer icon  

4. (b) The new vector layer dialog box will be displayed as shown in figure below.

 
Select point, line 
or polygon as per 
the requirement 

 

Type a name 

 

Select CRS as 
per choice, 
GCS or PCS 
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4. b (i) Choose any feature type i.e. point/line/polygon as the case may be.

4. b (ii) Select and specify the Coordinates Reference System (CRS).

4.b (iii) To complete the creation of New shapefile layer > go to New attribute field > specify any 
name>type (choose text ,decimal,whole number ,date) > then click add to attribute list> 
click OK.

 Give specific 
name to
shapefile as 
per the
choice

  

4. (c) After clicking ok option >save layer as dialog box will appear > then specify the  Drive and 
folder to save the output file>Give name to output file> click save.
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CHAPTER 5: 

5. (a) All editing session start by choosing the toggle editing option 
5. (b) Use the add features icon on the toolbar to add new features (point, line or polygon).

5. (c) Next start digitise the feature i.e. point, line or polygon, left-click on the map area to create the 
first point of your new feature >then enter its attributes (same way with both line and polygon).

5. (d) After digitizing click on save layer edits 
5. (e) To calculate area, length and perimeter > go to layer option > click on polygon features > right 

click.

DIGITIZING A NEW OR EDITING 
AN EXISTING LAYER
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5. (f) Select Open Attribute Table.

5. (g) One dialog box will appear> then click on toggling editing           mode to start Calculating area, 
length or perimeter.

5.(h) Then click on expression          (for calculating the length, perimeter and area).
5. (i) Expression dialog box will appear >in the function  option >select geometry >click on $area, 

$perimeter, $length (to calculate area/perimeter/length) > click ok> then click update all 
option (the software will automatically calculate the Area/length/perimeter as shown in figure 
below).
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CHAPTER 6: 

6. (a) To georeference the Google earth image > Go to menu bar >select Raster>select 
Georeference> open raster option > add the save Google earth image to Georeference > 
specify the CRS.
 Add point  

6. (b) After adding four points >go to setting>transformation setting> in the target SRS select 
the coordinate reference system (CRS) > specify the output file> click Ok Run (start 
georeferencing tool).

GEOREFERENCE A DOWNLOADED 
GOOGLE EARTH IMAGE
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Open 
raster

 

Start georeferencing tool



6. (c)  To compose the georeference image you have to follow steps 11a-d (pg. 37).
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CHAPTER 7: 

7. a (i) Open QGIS software > go to  add raster  layer icon       and click in the icon.
7. a (ii) Immediately one dialog box will appear in the frame > then click on the specific image> click 

open to add the image in the map canvas or frame.

HOW TO OPEN SATELLITE IMAGE 
(RASTER DATA) IN QGIS
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Image will appear as showing in Figure



7. a (iii)  Go to layer > click in the image > right click > go to properties > go to style option to change the 
band combination (for red band 3,green band 2 and blue band 1) >click apply then  ok.
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Image will appear as showing in Figure
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CHAPTER 8: 

CLIP

Clipping is the process by which a subset of the raster as well as vector dataset is created. Clipping 
removes data outside the area of interest reducing the file size and improving the processing time for 
many operations.
· The Clip tool allows you to extract a portion of a raster dataset based on a template extent. The clip 

output will include any pixels that intersect the template extent.
· The clipped area is specified either by a rectangular envelope using minimum and maximum x- 

and y-coordinates or by using a output extent file. If the clip extent specified is not aligned with the 
input raster dataset, this tool will make sure that the proper alignment is used. This may cause the 
output to have a slightly different extent than specified in the tool.

· Go to Raster > Extraction > Clip Raster by Extent.



 Subset/Clip of Raster Dataset
 

Input Final Output
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· Give clipping extent by selecting extent (through dragging to selected area) on canvas or use 
layer/ canvas as extent as per the availability and run the process.
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CHAPTER 9: 

9. a (i) Open the raster data or satellite image.

9. a (ii) Open the  vector data (shapefile of point, line or polygon).

SUPERIMPOSED A SHAPEFILE 
ON SATELLITE IMAGE



9. a (iii) Add the vector data (i.e. shapefile of point,line and polygon) from add vector layer icon.

 
Click here to add raster 

 

 
Click here to add vector 

9.b (i) To change weight (width) of point, line go to layers >select the point or line layer >right click on 
it> go to properties option (a layer properties dialog will appear).
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9. b (ii)Select style >go to width option and change the width of point or line as the case may be.

 Width 

 

Style 

 



9. c (i) To change colour of the point, line and polygon go to layer >double click  on the point polyline 
or polygon shapefile> a layer properties dialog box will appear > click on style option >change 
the colour of the shapefile.

 
Style  

 

Colour  

 

 

Q-GIS MANUAL    Page 32



 

Q-GIS MANUAL    Page 33

CHAPTER 10: 

10. a Add a satellite image in QGIS layer.

10. b (i) To create a shapefile of point, line and polygon go to new shapefile layer menu > click in the 
option new shapefile (refer Chapter 4 for creation of new shapefile).

 

DIGITIZATION OF VECTOR FEATURE 
(POINT, LINE AND POLYGON) 

ON SATELLITE IMAGE



10. b (ii) Start digitise the point feature, line feature and polygon with reference to the satellite image 
(villages or locality as point features, river and road network as line  features, open forest as 
polygon) .

10. b (iii) After digitising all  the features > save and stop the layer.
10.c (i) To name  the features > select any features (either point, line or polygon) > right click on it > 

select properties. 

 

Q-GIS MANUAL    Page 34



 

Q-GIS MANUAL    Page 35

10. c  (ii) Layer properties table will appear > select Labels > select the option Label this layer.  



10. c (iii) Select the name of features > adjust colour of text, size and font format from the table > click 
apply then ok.
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CHAPTER 11:

11. (a) To compose a map in QGIS >go to menu toolbar > click project> select new Print 
Composer.

 

New Print Composer 

 

Project 

 

11. (b) After clicking on the new print composer one dialog box will appear >compose title  > name 
the composer title.

11. (c) Opening the Print Composer provides you with a blank canvas that represents the paper 
surface when using the print option> click on add new map>drag it in the map canvas.

MAP COMPOSITION 
IN QGIS



11. (d) Go to layout toolbar to add label, scale bar, legend and north arrow >to generate or  add grid > 
click on item properties on the left side of map canvas > click on grid > add  grid (+) > specify 
the CRS >adjust the interval > select the draw coordinates option > change the format into 
degree decimal or degree minute second.

  

  

 North Arrow 
 Grid 

 Composed Map of Goa 
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Scalebar   
Legend

  
Arrow
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CHAPTER 12:

CREATION OF BUFFER

12. a (i) Open QGIS software > add vector data or shapefile of point, polyline and polygon.



12. a (ii) Go to vector menu click on it > go to Geoprocessing tools > select buffer.

 If Buffer option is not available in 
Geoprocessing tools then add 
mmqgis plugin to add. 

 

12. a (iii) After clicking on buffer option one dialog box will appear > specify or select the input vector 
layer > next specify the buffer distance (in meter) > then go to browse option > select a folder 
to save the output file > click ok (the software will automatically process and calculate the 
buffer).

 

Buffer distance, 
5km

 

To save file 
click here
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ANNEXURE
Geographic Information Systems (GIS)

Open Source Software (OSS)

Open Source Geospatial Foundation (OSGeo) 

General Public License (GPL)

Raster

Vector

GIS is a computer-based tool that analyzes, stores, 
manipulates and visualizes geographic information on a 
map.

OSS is a computer software with its source code made 
available with a license in which the copyright holder 
provides the rights to study, change and distribute the 
software for any purpose. Open source software is 
developed in a collaborative public manner.

It is a non-profit and non-governmental organization 
whose mission is to support and promote the collaborative 
development of open geospatial technologies, data, 
education and training. QGIS, GRASS, PostGIS, GDAL and 
GeoServer are projects of OSGeo (osgeo.org).

GPL is a free and widely used software license standard, 
which guarantees end users the freedom to run, study, 
share and modify the software. The license was originally 
written by the Free Software Foundation (FSF) for the 
GNU Project and grants the recipients of a computer 
program the rights of the Free Software Definition. The 
GPL is a copy left license, which means that derivative 
work can only be distributed under the same license terms.

Raster data in GIS are matrices of discrete cells that 
represent features of the earth's surface. Usually satellite 
or a real imagery is represented in Raster data format  like 
GeoTIFF, img, pix, hdf (Hierarchical Data Format) etc. 

Vector data is a coordinate-based data structure 
commonly used to represent point, linear and enclosed 
map features. Each linear feature is represented as  x, y 
coordinates. Attributes stored in a database are associated 
with the features. Vector data includes: 

1. Point features (Temple, Monuments, Forest Chowkies, 
Forest Fire Point, etc.)

2. Line features (Roads, Railways, Fences, Cart-tracks, 
Pack-Tracks, etc.)

3. Polygon features (Land Parcels, wetlands, forests, 
etc.)

Ground control points (GCPs

Coordinate reference system (CRS)

Buffer

Clip

Coordinates

Attribute table

Feature

Latitude

Longitude

Control points are precise points with specific lat/long 
coordinates to add manually so the georeferencing tool 
can accurately generate georeferenced layer.

A CRS is a system corresponding to a certain projection 
and algorithm. Some of them are based on a latitude / 
longitude base while others may respond to different 
algorithms. Usually, each geographic entity has one or 
several CRS which represents its best. The most common 
CRS used for global projections is WGS 84.

The buffer tool is a proximity function that creates a 
polygon at a set distance surrounding a selected feature or 
features.

 A clip is an overlay tool that involves clipping an input layer 
with the extent of a defined feature boundary. The result of 
this tool is a new clipped output layer.

Coordinates are sets of values representing one particular 
geographical point. They are usually composed of two (x, 
y) or three (x, y, z) dimensions, x representing a horizontal 
value, y a vertical one, and z elevation.

An attribute table stores non-spatial information in 
columns and rows about geographic data. 

A feature is a cartographic point, line or polygon object 
with a spatial location in the real-world landscape that can 
be used in a GIS for storage, visualization and analysis.

The latitude is a vertical coordinate, ranging from 0° (at the 
Equator) to 90° (North Pole) or -90° (South Pole). It 
corresponds to the y field in coordinates.

The longitude is a horizontal coordinate ranging from 0° at 
the Greenwich Meridian to 180° (East) and -180° (West). It 
corresponds to the x field in coordinates.

GLOSSARY AND ABBREVIATION
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Note: The latest release of QGIS is always available web page 
https://www.qgis.org/en/site/forusers/download.html

For further queries can connect m.bist83@gmail.com
Website: http://www.fsi.nic.in

Note: The latest release of QGIS is always available web page 

For further queries can connect m.bist83@gmail.com
Website: http://www.fsi.nic.in

https://www.qgis.org/en/site/forusers/download.html
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